diff configure.ac @ 5920:0f2338afbabf cygwin

Minimum necessary to get started: sufficient to compile OK, run -nw, but not with window
author Henry Thompson <ht@markup.co.uk>
date Mon, 21 Apr 2014 11:42:50 +0100
parents 4e69b24a2301
children 4b055de36bb9
line wrap: on
line diff
--- a/configure.ac	Thu Dec 16 11:20:17 2021 +0000
+++ b/configure.ac	Mon Apr 21 11:42:50 2014 +0100
@@ -1306,6 +1306,7 @@
   hppa-*-*         ) machine=hp800 ;;
   arm*             ) machine=arm ;;
   i[[3-9]]86-*-*   ) machine=intel386 ;;
+  x86_64-*-*       ) machine=x86_64 ;;
 esac
 
 dnl Straightforward OS determination
@@ -1391,6 +1392,14 @@
     test "$opsys $CC" = "sol2 /usr/ucb/cc" && CC=""
   ;;
 
+  dnl 64-bit machines where we do not care about the manufacturer
+  x86_64-*-* )
+    case "$ac_cv_build" in
+      *-cygwin* )	opsys=cygwin64 ;;
+      dnl Otherwise, we fall through to the generic opsys code at the bottom.
+    esac
+  ;;    
+
   dnl Intel 386 machines where we do not care about the manufacturer
   i[[3-9]]86-*-* )
     case "$ac_cv_build" in