diff configure.ac @ 4536:0ed907d0f1e9

configure,configure.ac: Fixed two typos in args of main: char *v -> char **v
author "Vladimir G. Ivanovic" <vgivanovic@comcast.net>
date Sat, 27 Dec 2008 15:28:43 +0000
parents 66411359ce4e
children 7ca6d57ce12d
line wrap: on
line diff
--- a/configure.ac	Mon Dec 22 14:07:48 2008 +0000
+++ b/configure.ac	Sat Dec 27 15:28:43 2008 +0000
@@ -3434,7 +3434,7 @@
 
   AC_MSG_CHECKING(the version of X11 being used)
   AC_RUN_IFELSE([AC_LANG_SOURCE([#include <X11/Intrinsic.h>
-    int main(int c, char *v[]) { return c>1 ? XlibSpecificationRelease : 0; }])],
+    int main(int c, char **v[]) { return c>1 ? XlibSpecificationRelease : 0; }])],
     [./conftest foobar; x11_release=$?],[x11_release=4],[x11_release=4])
   AC_MSG_RESULT(R${x11_release})
   AC_DEFINE_UNQUOTED(THIS_IS_X11R${x11_release})
@@ -5582,7 +5582,7 @@
 dnl One of the above link tests may have succeeded but caused resulting
 dnl executables to fail to run.  Also any tests using AC_RUN_IFELSE will
 dnl have reported incorrect results.
-AC_RUN_IFELSE([AC_LANG_SOURCE([int main(int c,char *v[]){return 0;}])],[:],[
+AC_RUN_IFELSE([AC_LANG_SOURCE([int main(int c,char **v[]){return 0;}])],[:],[
   echo ""
   echo "*** PANIC *** The C compiler can no longer build working executables."
   echo "*** PANIC *** Please examine the tail of config.log for runtime errors."