diff configure.in @ 2286:04bc9d2f42c7

[xemacs-hg @ 2004-09-20 19:18:55 by james] Mark all unused parameters as unused. Also eliminate some unneeded local variables.
author james
date Mon, 20 Sep 2004 19:20:08 +0000
parents 702b5727498a
children e2fdc9035c5b
line wrap: on
line diff
--- a/configure.in	Mon Sep 20 19:11:29 2004 +0000
+++ b/configure.in	Mon Sep 20 19:20:08 2004 +0000
@@ -2055,6 +2055,8 @@
     cflags_warning="-qinfo"
   elif test "$GCC" = "yes"; then
     cflags_warning="-Wall -Wno-switch -Winline -Wmissing-prototypes"
+    cflags_warning="$cflags_warning -Wunused-parameter -Wunused-variable"
+
     dnl Yuck, bad compares have been worth at least 3 crashes!
     cflags_warning="$cflags_warning -Wsign-compare"
     cflags_warning="$cflags_warning -Wundef -Wstrict-prototypes"